CT - Creative Technology

INST-07548, INST-07551 and jrf_wlsFmw with Oracle Middleware 12.2.1.3.0

When you try to install some of the Oracle Middleware components in version 12.2.1.3.0 and receive below errors at “Installation Location” stage then there is solution to pass it.

Errors which occur at the beginning of installation process:

  • INST-07548: The selected distribution does not have any compatible install type for the selected Oracle Home. Provide a different oracle Home. Check http://www.oracle.com/pls/topic/lookup?ctx=fmw122130&id=installhome for details about compatible products and install types.
  • INST-07551: Not all dependent featuresets for install type “Service Bus” could be found. One of the following needs to be selected:
    wls_coreEngine – 12.1.3.0.0
    jrf_wlsFmw – 12.2.1.3.0
    Select a different Oracle Home having all dependencies. Check http://www.oracle.com/pls/topic/lookup?ctx=fmw122130&id=installhome for details about compatible products and install types.
  • INST-07551: Not all dependent featuresets for install type “Service Bus” could be found. One of the following needs to be selected:
    wls_coreEngine – 12.1.3.0.0
    jrf_wlsFmw – 12.2.1.3.0
    Select a different Oracle Home having all dependencies. Check http://www.oracle.com/pls/topic/lookup?ctx=fmw122130&id=installhome for details about compatible products and install types.
INST-07548, INST-07551 and jrf_wlsFmw problems during Initiallization Location step during installation
INST-07548, INST-07551 and jrf_wlsFmw problems during Initiallization Location step during installation

Problem


I had INST-07548, INST-07551 and jrf_wlsFmw problem during installation of Oracle Service Bus 12.2.1.3.0 (V886445-01).

Reason

Problem is in buggy installer which doesn’t find required item in existing Oracle Weblogic installation. It is like that when you select Skip Auto Updates in Auto Updates installer step.

Solution

Workaround is trivial. You need to patch it. To do so you need to move back to Auto Updates step and change default Skip Auto Updates option to Search My Oracle Support for Updates where you have to provide your Oracle support credentials.

Search My Oracle Support for Updates option at Auto Update step during Oracle software installation
Search My Oracle Support for Updates option at Auto Update step during Oracle software installation

It should result in proposal of below patches to apply:

  • 22786409 – 13.9.3 PREFLIGHT ON FMW 12.2.1.3.1
  • 22058967 – ASINT PATCH FOR LOGS
Patches to apply 22786409 – 13.9.3 PREFLIGHT ON FMW 12.2.1.3.1 and 22058967 – ASINT PATCH FOR LOGS

It will offer to apply it on currently running installer and restart it. After you agree it runs correctly and now you can select Skip Auto Updates.

1 Comment

  1. @NjI

    Hi
    I tried the above option but is not working for FMW 12.2.1.4.0. I am getting the same issue.
    I did some analysis then find the solution.solustion is we need to install Oracle Fusion Middleware 12c Infrastructure first after that we need install if u need only OSB or SOA jar file. this jar contains that jrf_wlsFMW then the error is resolved. know I happily installed fmw_osb jar.

    Thank you 🙂

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.