Piotr GeoS Galas techblog

CT - Creative Technology

Tag: apache

Hosting w godaddy, a problem Error 404 przy zastosowaniu mod_rewrite

Dziś na jednym z kont posiadanych w godaddy chciałem dopisać regułkę mod_rewrite. Wszystko super, tylko niestety na hostingu współdzielonym dostawca ma problem z regułkami. Nie mniej i na to znalazło się wyjście.

Zakładając, że nasza reguła znajduje się w subdomena.domena.pl/pierwszyFolder/drugiFolder/ i przykładowo plik .htaccess wygląda następująco:

  1. RewriteEngine on
  2. RewriteRule ^przemapuj_(.*)$    index.php?zmienna=$1    [L]

Powinno to zostać zastąpione przez:

  1. RewriteEngine on
  2. RewriteBase /pierwszyFolder/drugiFolder/
  3. RewriteRule ^przemapuj_(.*)$    index.php?zmienna=$1    [L]

Już po komunikatach błędów widać, że niby ścieżka odwołania do docelowego pliku jest prawidłowa, a mimo to serwer ma problemy z jej znalezieniem. Dodanie RewriteBase je rozwiązuje.

Problem popsutej treści pod Apache / Problem of break down content under Apache

Od kilku miesięcy, jakoś po zmianie środowiska webdeveloperskiego z budowanego na własną rękę na WAMPa, występował u mnie problem popsutych/zmixowanych/rozjechanych/… obrazków, plików JavaScript i wszystkiego, co swoją treścią przekraczało 64KB (65535B).
Gdy od czasu do czasu trafiało się zlecenie i trzeba było wczytać do przeglądarki coś ponad te 64KB, to aż mnie szlag trafiał. Zaczynało się kombinowanie jak to obejść, później googlanie w celu znalezienia podobnego błędu u innych i jakiejś recepty na całe zło.
Okazało się, że rozwiązanie było dość proste i, co najśmieszniejsze, znalazłem je na forum poświęconym MS IIS.
Recepta wygląda tak – otwieramy plik konfiguracyjny httpd.conf i odkomentowujemy:

  1. EnableMMAP off
  2. EnableSendfile off

Być może jest jeszcze ktoś, kto męczy się z podobnym problemem i komu mój wpis pomoże (dotarcie do rozwiazania nie było dla mnie takie szybkie).

Above text tells that if you have problems with not proper showing images, loading scripts or any other content which Apache sends to your browser and what is bigger then 64KB (65535B) then it must be the same problem as I had for a few months (after changing webdevelopment plafromr to WAMP).
Solution is quite easy. Its enough just to uncomment in httpd.conf such lines:

  1. EnableMMAP off
  2. EnableSendfile off

I belive that this note can help also someone else as it wasn’t so easy (for me) to find it out.

PS Oryginalny link z rozwiązaniem / Oryginal link with solution:
http://www.sitepoint.com/forums/showpost.php?p=1840974&postcount=15

  • RSS
  • Blip
  • Twitter
  • Facebook
  • GoldenLine
  • LinkedIn
  • Nasza Klasa
  • Grono
  • Panoramio
  • YouTube